PDA

View Full Version : Forum issues


TFArchive
2009-10-06, 06:46 PM
If you have any issues with the forum, let me know here and I'll do what I can to fix them.

Thanks

zigzagger
2009-10-06, 07:20 PM
Hmm. I'm having trouble logging into the RPG wiki. Also, though it's not much, the updates made during last week on the wiki appear to be missing.

Denyer
2009-10-06, 07:40 PM
You won't be able to log in until I've rewritten that bit...

Previous content -- if Brendan gives me the IP address of the old server, I can possibly get just those files and move them across.

edit: It's probably better if I don't fix the login until we've got any previous server data we want imported.

edit2: Currently applying fixes to other bits. Short-term breakage may happen.

zigzagger
2009-10-06, 07:41 PM
You won't be able to log in until I've rewritten that bit...
Nah, looks to be sorted now. Thanks.

TFArchive
2009-10-06, 07:43 PM
Ah, I'm also working on fixing it. I'm dumping all the files to the new server as the copy of the site is a few days pre-migration. I also need to setup the permissions on all the data folders. I'll make the DB changes last.

Denyer, the previous servers IP is 75.126.7.130

Denyer
2009-10-06, 07:49 PM
Ah, I'm also working on fixing it. I'm dumping all the files to the new server as the copy of the site is a few days pre-migration.
Er, please not all of them as I've just spent the last hour or so changing database connections and non-relative references.

If you're also changing files, it might be better if I stop for the evening.

Denyer
2009-10-06, 08:48 PM
Got the /rpg/site/ directory, re-upping now. Depending on how things are set up with the new place, may then need to change ownership of the files.

If you could hold off on wiki edits whilst that's going on...

TFArchive
2009-10-06, 09:26 PM
Sorry man, I was in the middle of copying the files when you posted. I found a script that changed all the permissions at once so everything should be the same as the old server.

Sorry if this messed up anything you were doing :(

Denyer
2009-10-06, 11:01 PM
Doesn't seem to have -- it was mostly things under /fandom/. Couple more minor things to do, but it'll keep until tomorrow.

Can you chown what's in /rpg/site/data/ to 'apache' rather than 'ftp'? Think that should be ready to go then.

TFArchive
2009-10-07, 12:46 AM
Done, everything is looking good so far. :D

Selkadoom
2009-10-07, 12:56 AM
Yeah im not sure if this counts, but both chat rooms aren't working at all for me

TFArchive
2009-10-07, 01:47 AM
Sorry, I don't know much about the chat, I'll leave that for the experts.

Warcry
2009-10-07, 04:15 AM
Minor issue: the RPG site is showing the default DokuWiki favicon instead of the Archive one.

Denyer
2009-10-07, 06:20 AM
Yeah im not sure if this counts, but both chat rooms aren't working at all for me

I need to go through and change a few bits so that it can see vBulletin again -- should be quick to do when I get back from work.

Denyer
2009-10-07, 07:10 PM
Try it now.

Selkadoom
2009-10-07, 10:14 PM
Yeah works now thx

Warcry
2009-10-08, 03:36 AM
The toy checklists aren't displaying properly (white background, no top banner or sidebar).

[EDIT]Also, the search function isn't returning any results from before the move if you search on a text string, like what happened back when we upgraded the board.

Cliffjumper
2009-10-08, 04:55 PM
[EDIT]Also, the search function isn't returning any results from before the move if you search on a text string, like what happened back when we upgraded the board.

This.


I came in here to report it, and I was damned if I was leaving without giving my twopeneth.

Denyer
2009-10-08, 08:23 PM
It's been recompiling for an hour or two, will leave it running overnight.

Unfortunately the number of requests made to do it is making the site grindingly slow for me, but I've fixed files in the "articles", "checklists", "references" and "trademarks" folders in /toys/ and will do /mistransformed/ and any others when able, if Nevermore hasn't already gotten to them.

TFArchive
2009-10-09, 03:14 PM
Ah, that's what the site was doing last night, yes I deleted the search results from the database during the transition as it took over an hour to import the 14 million results even on the new system.

Thanks for taking care of these issues, I'm afraid I've been away from the nitty gritty of the site for too long to know were everything is. That and we have so many sections/modules it is hard to find some of them.

Denyer
2009-10-09, 08:51 PM
Had to do the last 15% or so of the search stuff this evening, but should now be fully indexed. Gonna go see if the FTP is happy again, hopefully upload a bit of comics stuff, search what files I've got offline for hardcoded paths, then crash, see if I can shift this bloody cough for next week and get better sleep.

Will aim to whip up a list of things with database connections at some point, also.

Cliffjumper
2009-10-09, 08:57 PM
Jawsome (http://www.youtube.com/watch?v=ug5NdQ1zLHE).